Error when installing Pumas.jl

Hi, may I have your help?

When I try to install the package, I get the following error:


ERROR: The following package names could not be resolved:

  • Pumas (not found in project, manifest or registry)

Please specify by known name=uuid.

When I try to clone from GitHub registry, I get the following error:


┌ Warning: Pkg.clone is only kept for legacy CI script reasons, please use add

@ Pkg.API /Users/julia/buildbot/worker/package_macos64/build/usr/share/julia/stdlib/v1.1/Pkg/src/API.jl:391

Cloning git-repo

Updating git-repo

Resolving package versions…

ERROR: Unsatisfiable requirements detected for package DiffEqDiffTools [01453d9d]:

DiffEqDiffTools [01453d9d] log:

├─possible versions are: [0.0.1-0.0.2, 0.1.0-0.1.2, 0.2.0-0.2.1, 0.3.0, 0.4.0-0.4.1, 0.5.0, 0.6.0, 0.7.0-0.7.1] or uninstalled

└─restricted to versions 0.14.0-0.14 by Pumas [4f2c3c20] — no versions left

└─Pumas [4f2c3c20] log:

├─possible versions are: 0.1.0 or uninstalled

└─Pumas [4f2c3c20] is fixed to version 0.1.0

Solved by using JuliaPro. Credit to Yingbo Ma


For future people having problems installing Pumas who find this thread, please see the installation instructions here .

1 Like

More issues found:

  1. If Atom version is higher than JuliaPro requests, you may get a “plain Atom editor” when opening JuliaPro. Solved by reinstalling JuliaPro and do not auto-update Atom.

  2. In JuliaPro REPL, you can only install PumasTutorial.jl by


which is cloning from GitHub, but you cannot install from registry currently.

  1. If you don’t have Jupyter, when opening notebook by


you may get an error after trying to install Jupyter via Conda. Solved by

Pkg"build Conda"

and try again.


Regarding 2 - you actually don’t need to install PumasTutorials.jl. Just use the links provided in the webpage and and follow them. We will update the page to take away the additional information that is not required.

Hey Nanfang! Right now the tutorials repo isn’t in the JuliaPro repository, so indeed you need to add from the URL for now (pkg"add"). JuliaPro should come with Jupyter notebooks though, so I’m surprised you had to rebuild Conda. I will look into that.

Let me know if you want to stop by the Julia Lab sometime this week. We can help get you up and running for what you need.

Thank you Chris and Vijay! I will definitely come this week! You are a very nice person.