(PFA license) fit function started hanging on Windows?


I am working with an Academic Pumas license on my Windows machine. On the first day after the installation everything worked fine and I could fit models within seconds to tens of seconds. However, on the second day fit() started hanging after getting called in the REPL even though I seemingly haven’t changed anything.

I’ve tried various things like re-installing, running on either Windows version of VSCode or WSL. Stuff like simobs or predict work fine. Any help or pointers would be very much appreciated, if any additional information would help - please let me know.

Hi Domus,

This is the first time we have heard about such an issue. Do you know where it hangs? E.g. by interrupting it or otherwise inspecting the process.


REPL becomes completely unresponsive to interrupts after calling fit(), in what other ways could I inspect the process to find where it hangs?

I would have thought that you would be able to interrupt the call with repeated ctrl+c but if that is not the case then it’s harder. On a Mac, you can inspect a running process by “sampling” it. That sometimes give a hint to what is going. Not sure if something similar is possible on Windows. You could also try to set ensemblealg=EnsembleSerial() to see if that makes a difference.

I’ve tried some more things and a different model - it seems to be due to a model issue. Specifically, if I change the prior on \Omega it leads to the uninterruptable hanging behaviour.