Can't load "Query" packge

all other packages are installed and loaded fine, but not “Query”. i using the “IV infusion” tutorial under nca, I tried running the line of code to use several of the packages. all of the packages were uploaded just fine, except “Query”. the error (since i can only embed one media image as a new user): “ArgumentError: Package Query not found in current path: _Run 'import Pkg; Pkg.add(“Query”) to install the Query”

since it seemed like the Query package wasn’t in my current path, i tried to re-route to the correct path, but wasn’t sure where. so, i then tried to re-install the package, as instructed by the prior error message, however when i tried that, here’s the error message i received:

can someone inform me where the Query package is found when downloading Pumas, or why i can’t install this new?


hi Cody,

that is unfortunate, but we can do most work without Query. Can you let us know which specific tutorial of IV infusion under NCA you are referring to as the current tutorials don’t have any specification or use of Query.


Hello Cody,

We have generally stopped using Query in our tutorials but this tutorial hadn’t been updated. I’ve just updated it such that it no longer uses Query and you can find the version at It will be included in the next Pumas distribution.

Hi, yes, that was the tutorial i was referring to. thank you for the update .