Error when using sigdigit in individual NCA


I am running a simple NCA analysis but i get an error when i run the code for the individual NCA parameters. When i remove the sigdigit argument it runs.

Can you help me set the desired significant digits for the individual NCA parameters?

vz        = NCA.vz(pop_oral_ss, sigdigit=3)

i get this error :

ERROR: MethodError: no method matching vz(::NCASubject{Nothing, Float64, Nothing, Float64, Nothing, NCADose{Float64, Int64}, Float64}; sigdigit=3)
Closest candidates are:
vz(::NCASubject{G, T, Nothing}; pred) where {G, T<:Union{Missing, Real, Quantity}} at /build/_work/PumasSystemImages/PumasSystemImages/julia_depot/packages/NCA/CDayS/src/simple.jl:302 got unsupported keyword argument “sigdigit”
vz(::Any, ::Any, ::Any…; dose, kwargs…) at /build/_work/PumasSystemImages/PumasSystemImages/julia_depot/packages/NCA/CDayS/src/NCA.jl:111
vz(::AbstractVector{T} where T<:NCA.AbstractNCASubject, ::Any…; label, interval, kwargs…) at /build/_work/PumasSystemImages/PumasSystemImages/julia_depot/packages/NCA/CDayS/src/NCA.jl:145

[1] kwerr(::NamedTuple{(:sigdigit,), Tuple{Int64}}, ::Function, ::NCASubject{Nothing, Float64, Nothing, Float64, Nothing, NCADose{Float64, Int64}, Float64})
@ Base ./error.jl:163
[2] (::NCA.var"#1070#1080"{Nothing, Base.Pairs{Symbol, Int64, Tuple{Symbol}, NamedTuple{(:sigdigit,), Tuple{Int64}}}, Tuple{}})(::Tuple{Int64, NCASubject{Nothing, Float64, Nothing, Float64, Nothing, NCADose{Float64, Int64}, Float64}})
@ NCA /build/_work/PumasSystemImages/PumasSystemImages/julia_depot/packages/NCA/CDayS/src/NCA.jl:117
[3] iterate
@ ./generator.jl:47 [inlined]
[4] collect
@ ./array.jl:724 [inlined]
[5] map
@ ./abstractarray.jl:2896 [inlined]
[6] vz(::Vector{NCASubject{Nothing, Float64, Nothing, Float64, Nothing, NCADose{Float64, Int64}, Float64}}; label::Bool, interval::Nothing, kwargs::Base.Pairs{Symbol, Int64, Tuple{Symbol}, NamedTuple{(:sigdigit,), Tuple{Int64}}})
@ NCA /build/_work/PumasSystemImages/PumasSystemImages/julia_depot/packages/NCA/CDayS/src/NCA.jl:116
[7] top-level scope
@ ~/data/code/Courses/PHMX_601/Week_4_NCA_II/3_MD_SS_Only.jl:89

@achamzas, you are getting an error unsupported keyword argument “sigdigit”.
Try with sigdigits (plural) as specified in the run_nca function (NCA Docstrings · Pumas).

All functions in NCA.*.jl uses sigdigits, if I am not mistaken.

Sorry, originally I had tried with sigdigits and was trying different methods to see if it would work. I just tried again with sigdigits and i get the same error.

run_nca runs correctly using the sigdigits but i see there is a problem when i am trying to use the individual NCA parameters function.

Since you have a DataFrame back from NCA.vz function just do a data wrangling step:

@rtransform! df :var = round(:var; digits=3)

where :var is the column name of the NCA computation.

Thank you very much for your help.